Add CSR1000v QCOW2 Image

After we have image qcow2, for example: “csr1000v-universalk9.16.06.05.qcow2”.

Step 1: create a directory (name of directory should be same with the image of qcow)

/opt/unetlab/addons/qemu/csr1000v-universalk9.16.06.05/

Step 2: upload it to eve-ng to the following directory:

/opt/unetlab/addons/qemu/csr1000v-universalk9.16.06.05/

step 3: rename the image filename of csr1000v-universalk9.16.06.05.qcow2 to virtioa.qcow2.

csr1000v-qcow

Step 4: add new lab in eve-ng.

csr1000v-qcow2

Advertisements

Commands in NCS 5500

There are some cli’s that I got from TAC and BU when troubleshooting Cisco NCS 5500 to find out any error or packet drop on line card. Here is:

TAC:

show controllers npu diag counters graphical instance all location 0/0/CPU0
show controllers npu stat counters-all detail instance all location 0/0/CPU0 | exclude ” 0″
show controllers npu stats traps-all instance all location 0/0/CPU0
show controllers fia diagshell 3 “diag counter g c” location 0/0/CPU0
show controllers npu stats voq base 1096 instance 3 location 0/0/CPU0
show controllers npu stats voq base 1088 instance 3 location 0/0/CPU0
show captured packets ingress location 0/0/CPU0
show captured packets ingress hexdump location 0/0/CPU0
show captured packets ingress interface Bundle-Ether40 location 0/0/CPU0
show spp node-counters location 0/0/CPU0
show netio idb Bundle-Ether30
show asic-errors all detail location 0/0/CPU0

show controllers npu voq-usage interface tenGigE 0/0/0/0/0 instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/0/1 instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/0/2 instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/1/0 instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/1/1instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/1/2 instance all location 0/0/CPU0

show controllers npu voq-usage interface tenGigE 0/0/0/10/0 instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/10/1 instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/10/2 instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/11/0 instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/11/1instance all location 0/0/CPU0
show controllers npu voq-usage interface tenGigE 0/0/0/11/2 instance all location 0/0/CPU0

show tech
show tech sysdb
show tech pfi
show tech ipinfra
show tech vrrp

From Developer Engineer/BU:

show cef vrf <vrf_name> <ipv4_destination> hardware egress detail location <>
fec and eedb dump for the above.

show tech-support ofa file
show tech-support dpa file
show tech-support cef mpls detail
show tech-support cef platform
show tech-support cef ipv4 detail
show tech-support ethernet interface
show tech-support arp file
show tech-support pfi file
show tech-support rib ipv4
show tech-support aib

show dpa trace
show ofa trace
show controllers fia diagshell 0 “ps” location all
show controllers fia diagshell 0 “diag nif” location all
show vether-driver fsm event verbose location <>
show vether-driver fsm error verbose location <>
show logging
show cli history detail
show redundancy
show mpls ldp forwarding summary
show cef mpls trace
show cef ipv4 detail
show mpls forwarding private detail
show controllers fia trace all verbose
show controllers npu resources all location <>

other TAC Engineer how to check NPU:

show controllers npu stats voq ingress interface all instance all location  0/0/cpu0
show controllers npu resources all location 0/0/cpu0
show processes cpu location 0/0/cpu0
show controllers npu voq-usage interface all instance all location 0/0/cpu0

 

Nge-lab lagi

hampir setahun ini vakum dari ngelab menggunakan GSN3/Eve, waktunya ngulik-ngulik. Kali ini ngelab DMVPN.

DMVPN=Dynamic Multipoint VPN,  konon katanya merupakan solusi yang ditawarkan oleh Cisco sebagai dynamic secure for overlay network [1]. DMVPN itu sebuah teknologi gabungan antara multipoint GRE, NHRP, IGP, dan IPsec, juga CEF, dimana dengan teknologi ini kita bisa membangun VPN multiple site tanpa harus melakukan konfigurasinya secara static. Site A bisa berkomunikasi dengan site B yang dihubungkan oleh “hub” secara dinamik. Site A dan B itu kita sebut “spoke”. Bayangkan MPLS VPN.

NHRP digunakan sebagai ‘lem’ atau ‘cache server’ antara client (spoke) dan server (hub). Petr Lavukhop menyebut NHRP ini mirip seperti ARP, dimana bisa dibikin static atau dynamic.

hub spoke

Berikut konfigurasi-nya interface:

R4#sh ip int br | ex down
Interface IP-Address OK? Method Status Protocol
Serial1/0 155.1.4.4 YES manual up up
Loopback0 150.1.4.4 YES manual up up
Tunnel0 192.168.0.1 YES manual up up

R4#sh run | in route
router eigrp 1
ip route 0.0.0.0 0.0.0.0 155.1.4.1
R4#

di R5 (spoke)

R5#sh ip int br | ex down
Interface IP-Address OK? Method Status Protocol
Serial1/0 155.1.5.5 YES manual up up
Loopback0 150.1.5.5 YES manual up up
Tunnel0 192.168.0.5 YES manual up up

R5#
R5#show run | in route
router eigrp 1
ip route 0.0.0.0 0.0.0.0 155.1.5.1
R5#

di R6.

R6#sh ip int br | ex down
Interface IP-Address OK? Method Status Protocol
Serial1/0 155.1.6.6 YES manual up up
Loopback0 150.1.6.6 YES manual up up
Tunnel0 192.168.0.6 YES manual up up

R6#show run | in route
ip route 0.0.0.0 0.0.0.0 155.1.6.1
R6#

 

Ada underlay dan overlay. Underlaynya adalah router connectivity sedangkan overlaynya adalah GRE tunnel. Lebih jelas bisa dibaca2 di link [2].

Konfigurasi underlaynya sudah dilakukan, sekarang overlaynya;

R4#sh run int tun0
Building configuration…

Current configuration : 243 bytes
!
interface Tunnel0
ip address 192.168.0.1 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication abc
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source Serial1/0
tunnel mode gre multipoint
tunnel key 123
end

R4#

R5#sh run int tun0
Building configuration…

Current configuration : 338 bytes
!
interface Tunnel0
ip address 192.168.0.5 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication abc
ip nhrp map multicast dynamic
ip nhrp map 192.168.0.1 155.1.4.4
ip nhrp map multicast 155.1.4.4
ip nhrp network-id 1
ip nhrp nhs 192.168.0.1
tunnel source Serial1/0
tunnel mode gre multipoint
tunnel key 123
end

R5#

R6#sh run int tun0
Building configuration…

Current configuration : 336 bytes
!
interface Tunnel0
ip address 192.168.0.6 255.255.255.0
no ip redirects
ip mtu 1400
ip nhrp authentication abc
ip nhrp map multicast dynamic
ip nhrp map 192.168.0.1 155.1.4.4
ip nhrp map multicast 155.1.4.4
ip nhrp network-id 1
ip nhrp nhs 192.168.0.1
tunnel source Serial1/0
tunnel mode gre multipoint
tunnel key 123
end

R6#

Verify:

R5#show ip nhrp
192.168.0.1/32 via 192.168.0.1
Tunnel0 created 00:08:51, never expire
Type: static, Flags: used
NBMA address: 155.1.4.4
R5#sh dmvpn
Legend: Attrb –> S – Static, D – Dynamic, I – Incomplete
N – NATed, L – Local, X – No Socket
# Ent –> Number of NHRP entries with same NBMA peer
NHS Status: E –> Expecting Replies, R –> Responding, W –> Waiting
UpDn Time –> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel0, IPv4 NHRP Details
Type:Spoke, NHRP Peers:1,

# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
—– ————— ————— —– ——– —–
1 155.1.4.4 192.168.0.1 UP 00:08:52 S

R5#

 

[1] https://blog.ine.com/2008/08/02/dmvpn-explained

[2] https://networklessons.com/cisco/ccie-routing-switching/introduction-to-dmvpn/

 

How to Breakout 40G Interface in Cisco NCS 5500

The first time project Cisco NCS 5500 that I received, there is a line card 24H1F (24 ports 100G and 12 ports 40G), with 40G port we can breakout into 4 x 10G pieces.

The default of 24H12F line card is 40G, but can support 100G if license is enabled. When it comes up, the interfaces are forty and hundred gigs.

RP/0/RP0/CPU0:ios#admin show platform 
 Thu Mar 22 04:16:18.070 UTC 
Location Card Type HW State SW State Config State 
---------------------------------------------------------------------------- 
0/0 NC55-24H12F-SE OPERATIONAL OPERATIONAL NSHUT 
0/RP0 NC55-RP OPERATIONAL OPERATIONAL NSHUT 
0/RP1 NC55-RP OPERATIONAL OPERATIONAL NSHUT 
0/FC0 NC55-5508-FC OPERATIONAL OPERATIONAL NSHUT 
0/FC1 NC55-5508-FC OPERATIONAL OPERATIONAL NSHUT 
0/FC2 NC55-5508-FC OPERATIONAL OPERATIONAL NSHUT 
0/FC3 NC55-5508-FC OPERATIONAL OPERATIONAL NSHUT 
0/FC4 NC55-5508-FC OPERATIONAL OPERATIONAL NSHUT 
0/FC5 NC55-5508-FC OPERATIONAL OPERATIONAL NSHUT 
0/FT0 NC55-5508-FAN OPERATIONAL N/A NSHUT 
0/FT1 NC55-5508-FAN OPERATIONAL N/A NSHUT 
0/FT2 NC55-5508-FAN OPERATIONAL N/A NSHUT 
0/SC0 NC55-SC OPERATIONAL OPERATIONAL NSHUT 
0/SC1 NC55-SC OPERATIONAL OPERATIONAL NSHUT 
RP/0/RP0/CPU0:ios#
P/0/RP0/CPU0:ios#sh ip int br 
 Thu Mar 22 04:17:00.667 UTC 
 
Interface IP-Address Status Protocol Vrf-Name 
MgmtEth0/RP0/CPU0/0 unassigned Shutdown Down default 
FortyGigE0/0/0/0 unassigned Shutdown Down default 
FortyGigE0/0/0/1 unassigned Shutdown Down default 
HundredGigE0/0/0/2 unassigned Shutdown Down default 
HundredGigE0/0/0/3 unassigned Shutdown Down default 
HundredGigE0/0/0/4 unassigned Shutdown Down default 
HundredGigE0/0/0/5 unassigned Shutdown Down default 
HundredGigE0/0/0/6 unassigned Shutdown Down default 
HundredGigE0/0/0/7 unassigned Shutdown Down default 
FortyGigE0/0/0/8 unassigned Shutdown Down default 
FortyGigE0/0/0/9 unassigned Shutdown Down default 
FortyGigE0/0/0/10 unassigned Shutdown Down default 
FortyGigE0/0/0/11 unassigned Shutdown Down default 
HundredGigE0/0/0/12 unassigned Shutdown Down default 
HundredGigE0/0/0/13 unassigned Shutdown Down default 
HundredGigE0/0/0/14 unassigned Shutdown Down default 
HundredGigE0/0/0/15 unassigned Shutdown Down default 
HundredGigE0/0/0/16 unassigned Shutdown Down default 
HundredGigE0/0/0/17 unassigned Shutdown Down default 
FortyGigE0/0/0/18 unassigned Shutdown Down default 
FortyGigE0/0/0/19 unassigned Shutdown Down default 
HundredGigE0/0/0/20 unassigned Shutdown Down default 
HundredGigE0/0/0/21 unassigned Shutdown Down default 
HundredGigE0/0/0/22 unassigned Shutdown Down default 
HundredGigE0/0/0/23 unassigned Shutdown Down default 
HundredGigE0/0/0/24 unassigned Shutdown Down default 
HundredGigE0/0/0/25 unassigned Shutdown Down default 
FortyGigE0/0/0/26 unassigned Shutdown Down default 
FortyGigE0/0/0/27 unassigned Shutdown Down default 
FortyGigE0/0/0/28 unassigned Shutdown Down default 
FortyGigE0/0/0/29 unassigned Shutdown Down default 
HundredGigE0/0/0/30 unassigned Shutdown Down default 
HundredGigE0/0/0/31 unassigned Shutdown Down default 
HundredGigE0/0/0/32 unassigned Shutdown Down default 
HundredGigE0/0/0/33 unassigned Shutdown Down default 
HundredGigE0/0/0/34 unassigned Shutdown Down default 
HundredGigE0/0/0/35 unassigned Shutdown Down default 
MgmtEth0/RP1/CPU0/0 unassigned Shutdown Down default 
RP/0/RP0/CPU0:ios#

To see more about NCS line cards, you can read NCS 5500 white paper  documentation and also can be searched in ciscolive.com.

To enable breakout in 40G, hereby the command:

NCS5500#config
NCS5500(config)#interface forty 0/0/0/0
NCS5500(config-if)#no shutdown
NCS5500(config-if)#exit
NCS5500(config)#controller optics 0/0/0/0
NCS5500(config-optics)#breakout 4x10
NCS5500(config-optics)#commit

The interface forty 0/0/0/0 will be change to Ten0/0/0/0/0 – 3.

To see the optical power level, use this command.

RP/0/RP0/CPU0:ios#show controllers optics 0/0/0/0 summary 
 Thu Mar 22 05:01:14.714 UTC 
 
Port Controller State Admin State LED State Lane Laser Bias TX Power RX Power 
 (dBm) (dBm) 
------------------ ---------------------- --------------------- ---------------- ----- ------------ ----------- ---------- 
Optics 0/0/0/0 Up In Service Yellow 0 6.8mA -1.87 -40.00 
 1 6.9mA -1.90 -11.14 
 2 6.8mA -1.72 -40.00 
 3 6.8mA -2.03 -40.00

Now, how about physical cable? The cisco guys, give this spec:

I found in fs.com [1], they have this type cable spec (I use transceiver LR and cable breakout single mode) and i bought from fs.com and it works.

I tried to use transceiver 40G SR and connect with multimode breakout cable and it does not work 🙂

Now, I am still waiting for MM cable breakout sent by fs.com to use 40G SR and multimode breakout cable.

[1] https://www.fs.com/products/41427.html

 

 

 

Putra Putri Nabi Muhammad SAW

Menurut beberapa sumber [1] & [2], putra nabi Muhammad SAW berjumlah 7 orang; 3 laki-laki dan 4 perempuan:

  1. Alqosim
  2. Zaenab
  3. Ruqoyah
  4. Ummu Kultsum
  5. Fatimah
  6. Abdullah
  7. Ibrahim

Putra Nabi meninggal sewaktu kecil, keempat putrinya yang tumbuh hingga menikah dan mempunyai keturunan. Keturunan Fatimah yaitu Hasan dan Husain.

[1] Teologi dan Ajaran Shi’ah Menurut Referensi Induknya. Insist Press.

[2] video youtube “ibu teladan terbaik – Ust Budi Ashari. https://www.youtube.com/watch?v=LHXYnYX3ZvE

Exam 400-101 CCIE RS Written

Tanggal 28 Sept 2017, langsung ambil written RS sebagai prasyarat mengambil ujian lab CCIE RS. Beberapa persiapan dilakukan dengan membaca beberapa bahan belajar:

  1. CCIE RS v5.1 Official Cert Guid – Narbik
  2. Video INE RS v5 Written
  3. Cisco documentation

Ujian dilakukan di UI Salemba, bareng seorang temen yang mudah-mudahan kami bisa bareng ujian lab dan lulus di akhir tahun 2017 atau awal 2018. Alhamdulillah, ujian written ini lulus dengan skor yang cukup. Biaya $450 pun tidak sia-sia.

Next, persiapan ngelab. Biaya ujian akan lebih mahal yaitu skitar $1600. Semoga bisa nabung dan lulus ujian. Masih ada waktu beberapa bulan untuk ujian lab.

Upgrade Mikrotik RouterOS

Baru kali ini belajar mikrotik. Setelah pasang Fastnet, dan koneksi Internetnya di-bridge ke Mikrotik. Lalu nyobain beberapa hal, salah satunya bridging wireless mikrotik dan upgrade RouterOS.

Step 1: Donlot OS mikrotik, cari aja di Internet.

Step 2: Copy paste file routerOS ke FTP nya mikrotik, dimana sample di mikrotik milik saya memiliki IP Address 192.168.88.1

Step 3:Verify file sudah terupload. Defaultnya di menu File akan tersimpan imagenya.

Step 4: Reload mikrotik. Buka winbox, buka System –> Reboot