Cisco Route Reflector

Kali ini kita akan belajar sedikit tentang BGP, Route reflector. Apa itu route reflector? silakan di baca-baca di sini [1] [2]. Berikut adalah topology dan konfigurasi yang saya ambil dari materi CCNP-Route.

rr

RR#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        192.168.1.6     YES NVRAM  up                    up
FastEthernet0/1        172.24.1.17     YES NVRAM  up                    up
Loopback0              200.100.50.1    YES NVRAM  up                    up
RR#

R1#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        192.168.1.5     YES NVRAM  up                    up
FastEthernet0/1        unassigned      YES NVRAM  administratively down down
POS1/0                 unassigned      YES NVRAM  administratively down down
R1#

R3#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        unassigned      YES NVRAM  administratively down down
FastEthernet0/1        172.24.1.18     YES NVRAM  up                    up
Loopback0              199.9.9.1       YES NVRAM  up                    up
R3#

Verify:

RR#sh run | sec bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
network 172.24.1.0 mask 255.255.255.0
network 192.168.1.4 mask 255.255.255.252
neighbor 172.24.1.18 remote-as 100
neighbor 172.24.1.18 route-reflector-client
neighbor 192.168.1.5 remote-as 100
neighbor 192.168.1.5 route-reflector-client
neighbor 192.168.1.5 prefix-list supernetonly out
no auto-summary
R1#sh run | se bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.6 remote-as 100
no auto-summary
R1#

R3#sh run | sec bgp
router bgp 100
no synchronization
bgp log-neighbor-changes
network 199.9.9.0
aggregate-address 199.0.0.0 255.0.0.0
neighbor 172.24.1.17 remote-as 100
no auto-summary
R3#

RR#sh ip route bgp
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route, + – replicated route

Gateway of last resort is not set

B     199.0.0.0/8 [200/0] via 172.24.1.18, 01:22:13
B     199.9.9.0/24 [200/0] via 172.24.1.18, 01:22:13
RR#sh ip bgp sum
BGP router identifier 200.100.50.1, local AS number 100
BGP table version is 4, main routing table version 4
3 network entries using 363 bytes of memory
3 path entries using 156 bytes of memory
4/3 BGP path/bestpath attribute entries using 304 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 823 total bytes of memory
BGP activity 3/0 prefixes, 3/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.24.1.18     4   100      96      94        4    0    0 01:23:29        2
192.168.1.5     4   100      93      95        4    0    0 01:22:15        0
RR#

RR#sh ip prefix-li
ip prefix-list supernetonly: 3 entries
   seq 5 permit 199.0.0.0/8
   seq 10 permit 172.24.1.0/24
   seq 15 permit 200.100.50.0/24
RR#

R3#sh ip bg sum | b Neighbor
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.24.1.17     4   100      95      97        5    0    0 01:24:34        1
R3#

R3#sh ip bgp
BGP table version is 5, local router ID is 199.9.9.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r>i192.168.1.4/30   172.24.1.17              0    100      0 i
*> 199.0.0.0/8      0.0.0.0                            32768 i
*> 199.9.9.0        0.0.0.0                  0         32768 i
R3#

R1#sh ip bgp
BGP table version is 2, local router ID is 192.168.1.5
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i199.0.0.0/8      172.24.1.18              0    100      0 i
R1#

RR#sh ip bgp
BGP table version is 4, local router ID is 200.100.50.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.4/30   0.0.0.0                  0         32768 i
*>i199.0.0.0/8      172.24.1.18              0    100      0 i
*>i199.9.9.0        172.24.1.18              0    100      0 i
RR#

 

[1] http://www.cisco.com/web/learning/le31/le46/cln/qlm/CCIP/bgp/introducing-route-reflectors-2/player.html

[2] http://www.dummies.com/how-to/content/the-basics-of-bgp-route-reflection.html

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s