LAB 1: OSPF di IOS-XR dan IOS

Sekadar mencoba IOS-XR virtual yang running di VirtualBox. Berikut labnya:

2. xr gns3

Note: untuk mengemulasikan IOS-XR di GNS3, bisa baca-baca di sini atau di google bisa dicari tata caranya.

Konfigurasikan masing-masing interface seperti tampak pada topology di atas. Lalu enable OSPF di masing-masing router berdasarkan network masing-masing, dan semuanya berada di area 0 (backbone).

R1#sh run | se ospf
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf hello-interval 5
ip ospf dead-interval 15
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-point
ip ospf hello-interval 5
ip ospf dead-interval 15
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.168.31.0 0.0.0.3 area 0
network 192.168.41.0 0.0.0.3 area 0
network 192.168.51.0 0.0.0.3 area 0
R1#

R1#sh ip int br | in up
FastEthernet0/0        192.168.51.1    YES manual up                    up
FastEthernet0/1        192.168.41.1    YES manual up                    up
FastEthernet1/1        192.168.31.1    YES manual up                    up
Loopback0              1.1.1.1         YES manual up                    up
R1#

Untuk R4:

R4#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        192.168.24.1    YES manual up                    up
FastEthernet0/1        192.168.41.2    YES manual up                    up
Loopback0              4.4.4.4         YES manual up                    up
R4#sh run | sec ospf
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-point
 ip ospf hello-interval 5
 ip ospf dead-interval 15
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-point
 ip ospf hello-interval 5
 ip ospf dead-interval 15
router ospf 100
 router-id 4.4.4.4
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 192.168.24.0 0.0.0.3 area 0
 network 192.168.41.0 0.0.0.3 area 0
R4#

Lalu konfigurasikan OSPF di sisi R2-XR dan R3-XR:

RP/0/0/CPU0:R2-XR#sh ip int br | in Up
Thu Jan 15 23:20:25.441 UTC
Loopback0                      2.2.2.2         Up                    Up
GigabitEthernet0/0/0/0         192.168.24.2    Up                    Up
RP/0/0/CPU0:R2-XR#sh run router ospf
Thu Jan 15 23:20:31.330 UTC
router ospf 100
 log adjacency changes
 router-id 2.2.2.2
 nsf cisco
 area 0
  interface Loopback0
   network point-to-point
  !
  interface GigabitEthernet0/0/0/0
   authentication message-digest
   message-digest-key 1 md5 encrypted 094F471A1A0A
   network point-to-point
   dead-interval 15
   hello-interval 5
  !

RP/0/0/CPU0:R3-XR#sh ip int br | in Up
Thu Jan 15 23:21:12.305 UTC
Loopback0                      3.3.3.3         Up                    Up
GigabitEthernet0/0/0/0         192.168.31.2    Up                    Up
RP/0/0/CPU0:R3-XR#sh run router ospf
Thu Jan 15 23:21:16.854 UTC
router ospf 100
 router-id 3.3.3.3
 area 0
  interface Loopback0
   network point-to-point
  !
  interface GigabitEthernet0/0/0/0
   authentication message-digest
   message-digest-key 1 md5 encrypted 0822455D0A16
   network point-to-point
   dead-interval 15
   hello-interval 5
  !

!

di kedua sisi menggunakan MD5 authentication. Lalu lakuka verify neighborship:

RP/0/0/CPU0:R3-XR#sh ospf nei
Thu Jan 15 23:22:39.969 UTC

* Indicates MADJ interface

Neighbors for OSPF 100

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1         1     FULL/  –        00:00:13    192.168.31.1    GigabitEthernet0/0/0/0
    Neighbor is up for 02:38:49

Total neighbor count: 1
RP/0/0/CPU0:R3-XR#sh route ospf
Thu Jan 15 23:22:44.618 UTC

O    1.1.1.1/32 [110/2] via 192.168.31.1, 02:38:53, GigabitEthernet0/0/0/0
O    2.2.2.2/32 [110/4] via 192.168.31.1, 01:22:17, GigabitEthernet0/0/0/0
O    4.4.4.4/32 [110/3] via 192.168.31.1, 01:22:17, GigabitEthernet0/0/0/0
O    5.5.5.5/32 [110/3] via 192.168.31.1, 01:55:52, GigabitEthernet0/0/0/0
O    192.168.24.0/30 [110/3] via 192.168.31.1, 01:22:17, GigabitEthernet0/0/0/0
O    192.168.41.0/30 [110/2] via 192.168.31.1, 02:22:25, GigabitEthernet0/0/0/0
O    192.168.51.0/30 [110/2] via 192.168.31.1, 01:55:52, GigabitEthernet0/0/0/0
RP/0/0/CPU0:R3-XR#

pun begitu di R2-XR

RP/0/0/CPU0:R2-XR#sh ospf ne
Thu Jan 15 23:23:31.198 UTC

* Indicates MADJ interface

Neighbors for OSPF 100

Neighbor ID     Pri   State           Dead Time   Address         Interface
4.4.4.4         1     FULL/  –        00:00:11    192.168.24.1    GigabitEthernet0/0/0/0
    Neighbor is up for 02:20:55

Total neighbor count: 1
RP/0/0/CPU0:R2-XR#sh route ospf
Thu Jan 15 23:23:34.748 UTC

O    1.1.1.1/32 [110/3] via 192.168.24.1, 01:23:08, GigabitEthernet0/0/0/0
O    3.3.3.3/32 [110/4] via 192.168.24.1, 01:23:08, GigabitEthernet0/0/0/0
O    4.4.4.4/32 [110/2] via 192.168.24.1, 01:29:31, GigabitEthernet0/0/0/0
O    5.5.5.5/32 [110/4] via 192.168.24.1, 01:23:08, GigabitEthernet0/0/0/0
O    192.168.31.0/30 [110/3] via 192.168.24.1, 01:23:08, GigabitEthernet0/0/0/0
O    192.168.41.0/30 [110/2] via 192.168.24.1, 01:29:31, GigabitEthernet0/0/0/0
O    192.168.51.0/30 [110/3] via 192.168.24.1, 01:23:08, GigabitEthernet0/0/0/0
RP/0/0/CPU0:R2-XR#

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s