L2VPN – EoMPLS

Baru belajar L2VPN, agak telat juga nih.

Secara umum L2VPN dibagi 2 yaitu

1. VPWS –> Point to Point

2. VPLS –> Point to Multipoint

Keduanya dibagi-bagi lagi berdasarkan beberapa hal.

VPWS dibagi lagi menjadi 2 kategori:

VPWS:

1. IP Core –> L2TPv3

L2TP dibagi lagi:

  • -Ethernet
  • -Frame Relay
  • -ATM
  • -PPP

2. MPLS core –> AToM (any transport over mpls)

AToM:

  • -Ethernet
  • -Frame Relay
  • -ATM
  • -PPP & HDLC
  • -Circuit Emulation

Nah, VPLS hanya di MPLS core –> Ethernet

Secara infrastruktur, ada CE1-PE1-P-PE2-CE2.

Dalam L2VPN, ada istilah beberapa istilah yang perlu dipahami:

1. PW=pseudo wire = kabel semu, bukan kabel asli. Jika kita ingin menghubungkan CE1 ke CE2 secara langsung, maka harus dibuat kabel dari CE1 ke CE1 yang melalui PE1, P dan PE2. Nah karena CE ini tidak selalu satu site, jika site berbeda dan berjauhan maka kalo narik kabel langsung kan repot. Maka digunakanlah ‘kabel semu’ yang diemulasikan di jaringan service provider. Si service providerlah yang membuat jalur semu agar CE1 to CE2 terhubung. Jalur itu kita sebut tunnel.

2. AC=attachment circuit

Apa itu AC ? hmmm, apa ya?? kita ambil definisi dari ebook saja. AC yaitu sirkuit physical atau sirkuit virtual (VC) antara CE dan PE. Virtual Circuit (VC) ini bisa berupa sebuah ethernet port, atm, VLAN, HDLC atau koneksi PPP [bisa dibaca di ebook “MPLS configuration on IOS software”). Pasti bingung ya? sama kalo begitu.. ūüôā

3. Emulated Circuit, yaitu yang melakukan koneksi antara CE ke CE.

mari kita coba dengan GNS3 (Ethernet over MPLS, EoMPLS) dengan topology berikut:

Konfigurasi P (R3):

R3#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        192.168.13.2    YES NVRAM  up                    up
FastEthernet0/1        192.168.23.2    YES NVRAM  up                    up
Loopback0              192.168.38.1    YES NVRAM  up                    up
R3#

R3#sh run | sec ospf
router ospf 1
router-id 192.168.38.1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
R3#show mpls inter
Interface              IP            Tunnel   BGP Static Operational
FastEthernet0/0        Yes (ldp)     No       No  No     Yes
FastEthernet0/1        Yes (ldp)     No       No  No     Yes
R3#

Konfigurasi PE1 (R1):

R1#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.13.1    YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
FastEthernet0/1.10         unassigned      YES unset  up                    up
Loopback0                  192.168.32.1    YES NVRAM  up                    up
R1#

R1#sh mpls interf
Interface              IP            Tunnel   Operational
FastEthernet0/0        Yes (ldp)     No       Yes
R1#

router ospf 1
router-id 192.168.32.1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
R1#

Konfigurasi PE2 (R2)

R2#
R2#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.23.1    YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
FastEthernet0/1.10         unassigned      YES unset  up                    up
Loopback0                  192.168.42.1    YES NVRAM  up                    up
R2#sh run int fa0/1.10
Building configuration…

Current configuration : 105 bytes
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
xconnect 192.168.32.1 10 encapsulation mpls
end

R2#show run | sec ospf
router ospf 1
router-id 192.168.42.1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
R2#sh mpls inter
R2#sh mpls interfaces
Interface              IP            Tunnel   Operational
FastEthernet0/0        Yes (ldp)     No       Yes
R2#

Konfigurasi CE1 (R4):

R4#sh ip int br | in up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
FastEthernet0/1.10         172.16.10.1     YES NVRAM  up                    up
R4#sh run int fa0/1.10
Building configuration…

Current configuration : 98 bytes
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 172.16.10.1 255.255.255.0
end

R4#

Konfigurasi CE2(R5):

R5#sh ip int br | in up
FastEthernet0/1            unassigned      YES NVRAM  up                    up
FastEthernet0/1.10         172.16.10.2     YES NVRAM  up                    up
R5#sh run int fa0/1.10
Building configuration…

Current configuration : 98 bytes
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 172.16.10.2 255.255.255.0
end

Verifikasi:

R4#ping 172.16.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/97/148 ms
R4#show arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet¬† 172.16.10.1¬†¬†¬†¬†¬†¬†¬†¬†¬†¬†¬†¬† –¬†¬† c200.1c84.0001¬† ARPA¬†¬† FastEthernet0/1.10
Internet  172.16.10.2             0   c201.1c84.0001  ARPA   FastEthernet0/1.10
R4#

R5#ping 172.16.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/95/148 ms
R5#show arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.10.1             1   c200.1c84.0001  ARPA   FastEthernet0/1.10
Internet¬† 172.16.10.2¬†¬†¬†¬†¬†¬†¬†¬†¬†¬†¬†¬† –¬†¬† c201.1c84.0001¬† ARPA¬†¬† FastEthernet0/1.10
R5#

Kita cek ARP tabelnya di masing-masing CE, padahal sudah berbeda network, beda router. Kok demikian? Nah seolah-olah antara CE1 dan CE2 itu satu switch.

Selamat mencoba.

 

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s