Cisco VPLS BGP Autodiscovery Configuration

Terinspirasi di Project BGP LU (Unified MPLS), dimana ada case customer VPLS BGP Autodiscovery mengalami problem saat dimigrasi ke BGP-LU. Maka saya mencoba mensimulasikannya dengan mengaktivasi VPLS. Simulasi dilakukan di GNS3 0.8.7.

Di GNS3, mayoritas menggunakan Cisco 7200 dengan IOS Version 15.2(4)S7 sebagai P routernya. Di Cisco 7200, tidak memungkinkan enable VPLS sehingga saya gunakan CSR1000v yang running di virtual box.

vpls bgp-ad

R21 (21.21.21.21) adalah CSR1Kv-R1, R22 (22.22.22.22) dan R23(23.23.23.23) adalah CSR1000v. Sisanya menggunakan Cisco IOS 7200 dan 3725 (CE).

Berikut konfigurasi VPLS di R23.

CSR1k-R23#sh run | sec l2vpn
l2vpn vfi context VPLS-BGP-AD
vpn id 200
autodiscovery bgp signaling bgp
ve id 3
rd 4761:1234
route-target export 4761:1234
route-target import 4761:1234
address-family l2vpn vpls
neighbor 21.21.21.21 activate
neighbor 21.21.21.21 send-community extended
neighbor 21.21.21.21 suppress-signaling-protocol ldp
neighbor 22.22.22.22 activate
neighbor 22.22.22.22 send-community extended
neighbor 22.22.22.22 suppress-signaling-protocol ldp
CSR1k-R23#

CSR1k-R23#sh run | sec bridge-domain
bridge-domain 200
member GigabitEthernet3 service-instance 200
member vfi VPLS-BGP-AD
CSR1k-R23#
CSR1k-R23#sh run int gi3
Building configuration…

Current configuration : 126 bytes
!
interface GigabitEthernet3

description to CE-VPLS23
no ip address
negotiation auto
service instance 200 ethernet
encapsulation untagged
!
end

CSR1k-R3#

Konfigurasi di CSR1k-R1 dan CSR1k-R2 adalah sama, kecuali untuk ve id (ve=virtual expansion, vpls edge), dimana parameter ini unik aka harus berbeda tiap router. Lakukan preconfig yang meliputi IP P2P, IGP (ospf), mpls ldp, dan bgp.

CSR1k-R1 ve=1.

CSR1k-R2 ve=2

CSR1k-R23#show bridge-domain
Bridge-domain 200 (2 ports in all)
State: UP                    Mac learning: Enabled
Aging-Timer: 300 second(s)
    GigabitEthernet3 service instance 200
    vfi VPLS-BGP-AD neighbor 22.22.22.22 200
   AED MAC address    Policy  Tag       Age  Pseudoport
   1   FFFF.FFFF.FFFF flood   static    0    OLIST_PTR:0xe7f64400
   0   C20A.154C.0000 forward dynamic   291  GigabitEthernet3.EFP200
   0   C20B.154C.0000 forward dynamic   300  VPLS-BGP-AD.1004012

CSR1k-R23#

Verify di sisi CE.

CE-VPLS2#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.0.2      YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Loopback0                  172.16.1.2      YES NVRAM  up                    up
Loopback10                 172.16.10.2     YES NVRAM  up                    up
CE-VPLS2#

CE-VPLS2#show ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.3        1   FULL/BDR        00:00:39    172.16.0.3      FastEthernet0/0
CE-VPLS2#

CE-VPLS3#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.16.0.3      YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Loopback0                  172.16.1.3      YES manual up                    up
CE-VPLS3#
CE-VPLS3#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.2        1   FULL/DR         00:00:33    172.16.0.2      FastEthernet0/0
CE-VPLS3#

CE-VPLS3#sh ip route ospf
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O       172.16.10.2/32 [110/11] via 172.16.0.2, 00:10:22, FastEthernet0/0
O       172.16.1.2/32 [110/11] via 172.16.0.2, 00:10:22, FastEthernet0/0
CE-VPLS3#

So, VPLS dengan BGP Autodiscovery dan signallingnya BGP pun berhasil. Masing-masing CE sudah bisa saling ngobrol dan melakukan sharing route ospf.

Untuk CSR1Kv-R1 tidak dihidupkan dikarenakan memory-nya tidak cukup sebab minimum memory untuk CSR1000v ini adalah 2.5GB x3 unit, sedangkan laptop saya hanya 12GB. Dan di topologi ini juga terdapat XRv (1.7GB) dan beberapa router 7200.

Jadi sementara hanya bisa running 2 unit CSR.

Finally, setelah mengurangi alokasi memory untuk router-router 7200 akhirnya 2 unit CSR1000v bisa running juga.

CSR1Kv-R1#show bridge-doma
Bridge-domain 200 (3 ports in all)
State: UP                    Mac learning: Enabled
Aging-Timer: 300 second(s)
GigabitEthernet3 service instance 200
vfi VPLS-BGP-AD neighbor 22.22.22.22 200
    vfi VPLS-BGP-AD neighbor 23.23.23.23 200
AED MAC address    Policy  Tag       Age  Pseudoport
0   CA0F.1F54.0008 forward dynamic   299  GigabitEthernet3.EFP200
1   FFFF.FFFF.FFFF flood   static    0    OLIST_PTR:0xe7f5d800
0   C20A.154C.0000 forward dynamic   298  VPLS-BGP-AD.1004017
0   C20B.154C.0000 forward dynamic   299  VPLS-BGP-AD.1004016

CSR1Kv-R1#

verify di sisi R23.

CSR1k-R23#show bridge-domain
Bridge-domain 200 (3 ports in all)
State: UP                    Mac learning: Enabled
Aging-Timer: 300 second(s)
GigabitEthernet3 service instance 200
vfi VPLS-BGP-AD neighbor 22.22.22.22 200
    vfi VPLS-BGP-AD neighbor 21.21.21.21 200
AED MAC address    Policy  Tag       Age  Pseudoport
0   CA0F.1F54.0008 forward dynamic   297  VPLS-BGP-AD.1004013
1   FFFF.FFFF.FFFF flood   static    0    OLIST_PTR:0xe7f64400
0   C20A.154C.0000 forward dynamic   299  GigabitEthernet3.EFP200
0   C20B.154C.0000 forward dynamic   300  VPLS-BGP-AD.1004012

CSR1k-R23#

CSR1k-R23#show l2vpn vfi name VPLS-BGP-AD
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No

VFI name: VPLS-BGP-AD, state: up, type: multipoint, signaling: BGP
VPN ID: 200, VE-ID: 3, VE-SIZE: 10
RD: 4761:1234, RT: 4761:200, 4761:1234
Bridge-Domain 200 attachment circuits:
Pseudo-port interface: pseudowire100001
Interface          Peer Address    VE-ID  Local Label  Remote Label    S
pseudowire100004   21.21.21.21     1      16           18              Y
pseudowire100003   22.22.22.22     2      17           18              Y

CSR1k-R23#

CSR1k-R23#show bgp l2vpn vpls all | b Network
Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 4761:1234
*>i 4761:1234:VEID-1:Blk-1/136
21.21.21.21              0    100      0 ?
* i                  21.21.21.21              0    100      0 ?
*>i 4761:1234:VEID-2:Blk-1/136
22.22.22.22              0    100      0 ?
*>  4761:1234:VEID-3:Blk-1/136
0.0.0.0                            32768 ?
CSR1k-R23#

Lebih lanjut bisa membaca dokumen-dokumen dari cisco.com atau lainnnya.

[1] https://supportforums.cisco.com/document/146416/l2vpn-using-bgp-auto-discovery-signaling

[2] http://www.cisco.com/c/en/us/support/docs/ios-nx-os-software/virtual-private-lan-services-vpls/116121-tech-vpls-bgp-00.html

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s