Gagal 2017#2: Ditolak

Gagal di tahun 2017 #2 adalah lamaran ditolak. Sehari sebelum keluargaku datang, tiba-tiba ortunya membatalkan. Padahal seminggu sebelumnya, ortunya memintaku dan keluarga datang.

silakan aa nyari yang lain, neng mah blom mau nikah.

Padahal, waktu awal kenalan:

kalo aa mau serius, datang ke wali neng dan memintanya untuk dinikahkan. neng mah gak bisa nentuin.

Time heals every wound, begitu kata Ikal. Nah, yang selanjutnya tak usah diceritakan lebih detil. You must be know the ending.

Setelah beberapa hari, beberapa minggu merenung, baru sadar bahwa “ditolak” ini adalah ‘balasan’ atas penolakan saya pada seorang wanita beberapa bulan/tahun sebelumnya. Kalo pernah menolak, suatu saat akan ditolak. Impaslah. Istilah kita-nya, amal baik akan diganjar dengan kebaikan, dan sebaliknya, berbuat keburukan maka akan ada balasan atas keburukan yang kita lakukan. Ya, harus sadar dan introspeksi diri. Masya Allah.

Hikmah lainnya adalah kemungkinan besar (99%) saya ini belum baik, belum layak, belum pantas jadi calon suami, atau Allah punya skenario lain untuk kehidupan saya esok. Kudu memperbaiki diri, memantaskan diri, memlerbaiki hati, menyiapkan ilmu agar siap menjadi kepala rumah tangga, menjadi imam keluarga.

Harus memperbaiki kualitas ibadah sholat, shaum senin & kamis, sholat sunnah rowatib, sholat malam, tingkah laku, ucapan, cara bicara dan artikulasi, pokoknya semuanya kudu diperbaiki.

Advertisements

Gagal 2017#1

Maret 2017, meluncur dari Surabaya meninggalkan ruang meeting lebih awal selepas beres giliran presentasi menuju Jakarta. Tiba di Jakarta tengah malam dengan pesawat paling akhir. Lelah tak bisa ditahan, tidur nyenyak hingga subuh.

Selepas subuh, baca-baca buku persiapan TOEFL. Dan meluncur ke Kaplan Educ. Ah, tak tau dimana juga itu lokasinya, berbekal google. Jadwal test hanya hari Jumat itu saja sebab di semua tempat ujian sudah full book.

Masuk ruang tunggu, menyapa salah satu peserta ujian yang nampaknya sedang baca-baca materi toefl. Menyapa dan bertanya, ternyata beliau sama-sama sedang persiapan buat ambil pasca dan juga beasiswa. Alumni FKUI, seorang dokter, wanita dan tentu saja cantik.  Beliau akan ambil S2 di UI. Ah sayangnya tidak berkenalan lebih lanjut sebab pikiran masih bergelayut dengan kerjaan di Surabaya, butuh submit dokumen dll.

Jam masuk segera diumumkan, waktu pun begitu cepat. Soal-soal listening part A dan B cukup enak dijawab. Part C mulai buyar konsentrasi. Lanjut part Structure. Lumayan tidak begitu sulit. Nah, part terakhir, Reading, menjadi kacau balau. Wacana dalam cerita begitu panjang, dimana butuh konsentrasi dan kemampuan vocabularay. Alhasil, tidak semua bisa dijawab. 10 soal lebih dijawab asal-asalan karena tak sempat membaca wacana. Waktu pun habis. Dan penyesalan pun melanda, kurang persiapan (alibi red.). Firasat buruk menghampiri.

Jreng-jreng, seminggu kemudian hasilnya diterima. Firasat buruk pun ternyata benar. Score-nya hanya 490. Score yang di bawah rata-rata. Beberapa tahun lalu score-nya sering di atas 500 dan tahun ini meluncur ke papan bawah.

Kegagalan #1 di tahun 2017, score TOEFL melemah. Kemampuan bahasa inggris menurun. Hikmah: harus banyak listening, and always understanding :-).

 

Cisco Nexus 7K & 9K Local Authentication and Tacacs

Ada satu hal yang membuat saya bingung ketika AAA diaktifkan di Nexus 5K:

  • N5K bisa authenticate menggunakan user lokal dan sekaligus user tacacs (external).
  • N5K command authentication defaultnya bisa diset tacacs juga local

aaa authentication login default group tacacs local

Hal ini berbeda dengan 7K dan 9K, dimana ketika aaa diaktifkan maka akan hanya berlaku salah satu saja. Nah, juga di kedua nexus ini, tidak ada command “local” setelah group tacacs. Dimana menurut dokumentasinya, jika tacacs masih available maka autentikasi akan ke tacacs, namun jika tidak available akan menuju local. User local akan hidup by default jika tacacsnya tidak available. Berikut command aaa di N7K/9K.

aaa authentication login default group tacacs

Cisco TAC pun menjawab pertanyaan saya bahwa behaviornya jika tacacs aktif maka local tidak bisa digunakan. Tidak bisa aktif dua-duanya. TAC dari tim Nexus bilang bahwa kesimpulan ini ia dapatkan setelah diskusi dengan tim AAA/Security.  Namun ketika saya konfrontasi dengan menunjukan ‘keanehan’ tersebut, kenapa di N5K bisa hidup dua-duanya? Hmm, TAC blom menjawab. Meraka bingung atau mereka gak mau tau ya 🙂

Nah, bagaimana dengan Cisco IOS dan XR?

 

Cisco Nexus 9K dot1q Tunnel

PoC yang aneh beberapa minggu lalu. Nexus 9K dijadiin switch aggregate dan diminta compliance dengan teknologi metro. Beberapa tidak support seperti ring protection. Dot1q tunnel pun hanya support di Nexus 9K seri EX. Namun unggul di kapasitas, bisa 40G. Kalo menggunakan Cisco M3600/3800, atau 903/920 memang spesialis di Metro namun dari sisi kapasitas belum support 40G (cmiiw).

!

system dot1q-tunnel

interface eth1/25

switchport mode dot1q-tunnel

switchport vlan mapping 100 dot1q-tunnel 50

switchport access vlan 50

no shutdown

!

 

Halal Food di Singapura

Pameran tahunan di Singapore, Communicasia 2017, mempertontonkan berbagai produk dan teknologi ICT dari infrastruktur jaringan, IoT, big data, knowledge management, hingga smart city.


Acaranya dilaksanakan 23-25 Mei 2017 di Marina Bay Sands Singapura mulai puk 10:30 hingga 5 sore. Saya hadir di dua hari terakhir. Keliling dari lantai B2 hingga level 5. Di level 5 tempat registrasi dan lokasi-lokasi para exibitor memamerkan berbagai produk dan teknologinya. Juga ada beberapa venue diisi dengan presentasi dari para exibitor.

Dari pagi hingga sore sekitar pukul 5:30, keliling dari satu venue ke venue lainnya. Laparpun mendera. Nyari makanan yang halal ternyata tidak segampang di Jakarta. Food court di sekitaran Marina Bay, umumnya menyediakan makanan berbasis daging babi, mulai dari sate , soup, hingga pork bacon. Maklum, penduduk singapur mayoritas beretnis chinese. Jadi wajar, makanannya jenis ini banyak ditemukan dimana-mana, mulai dari hotel, food court hingga cafe dan restoran.

Bagi yang Muslim, babi sangat diharamkan baik dikonsumsi maupun digunakan dalam produk lainnya.

Saya dan teman pun nyari-nyari. Alhamdulillah di sekitaran Hall di Marina Bay Sand ada satu yang bisa ditemukan: A Taste of Nanyang, posisinya di B1 sebelah selatan hall exibition, food court yang bersertifikat halal dari lembaga semacam MUI singapur. Posisinya bersebrangan dengan food court yang jual makanan yang mengandung babi. 

Kami pun makan agak telat skitar pukul 2.30 siang karena harus nyari ke beberapa food court dan menemukan lokasi persisnya, berbekal google map.


Harganya lumayan, berkisar $6 – 15 singapur untuk satu porsi makan. Plus minuman skitar $1.5-4. Ada menu nasi lemak, nasi kari ayam, mie ayam hingga cendol.

Saya memesan kari ayam dan segelas kopi hitam panas. Rasanya ya lumayan di lidah lah dibanding makanan india. Rada kemelayua-melayuan. Lidah saya pun cukup bersahabat dengan makanan melayu.

Ibuku sayang

Ba’da sholat Ashar, saya dan seorang teman lama ngobrol ngaler ngidul di tengah rumah sambil ngopi-ngopi sembari menunggu hujan mereda. Sesekali temanku ini memetik gitar menyanyikan beberap lagu. Saya hanya bisa menyimak petika gitar. Temanku ini lihai sekali main gitar, beliau orang bandung, yang umumnya banyak yang pandai memainkan gitar. Saya pun diajari beberapa teknik dasar memetik gitar yang lama sekali tak pernah diasah. Saya pun mulai memetik dengan teknik yang diajarkannya. Dan tak sabar untuk menyanyikan lagu favorit: Ibu (Iwan Fals).

Ribuan kilo jalan yang kau tempuh

Lewati rintang untuk aku anakmu

Ibuku sayang masih terus berjalan

Walau tapak kaki, penuh darah… penuh nanah
Seperti udara… kasih yang engkau berikan

Tak mampu ku membalas…ibu…ibu
Ingin kudekat dan menangis di pangkuanmu

Sampai aku tertidur, bagai masa kecil dulu

Lalu doa-doa baluri sekujur tubuhku

Dengan apa membalas…ibu…ibu….
Seperti udara… kasih yang engkau berikan

Tak mampu ku membalas…ibu…ibu

Kalo memainkan lagu ini, jadi teringat sama ibu yang sudah lama tiada, kadang suka meneteskan air mata tanpa sadar.

Tiba-tiba suara telpon berdering keras dan berkali-kali. Segera saja ku sambar telepon dan ku jawab salamnya.

my sister: wahaji Dersi teu aya.

me: innalillahi wainnailihi roojiuun.

Ternyata di akhir April 2017 ini satu-satunya uwa perempuan pulang ke rohmatullah. Beliau adalah kakaknya ibuku, orang yang paling dekat dan bahkan mirip wajahnya dengan ibuku. Dua minggu lalu beliau masuk rumah sakit karena sudah tidak bisa masuk apapun ke dalam tubuhnya. Rupanya sang kholik sudah menjemputnya.

Saya pun segera order Go-Jek dan meluncur ke terminal untuk pulang kampung. Sampai di kampung halaman ternyata sudah tengah malam, dan jenazahnya pun sudah dikebumikan.

Selepas subuh, saya pun berziarah ke makamnya. Makamnya tepat di samping teteh-nya, anak tertua, dimana sudah duluan berpulang ke rohmatulloh. Berdoa beberapa baris doa untuk uwa dan juga menziarahi ibu dan bapakku yang makamnya hanya beberapa meter dari makam uwa.

allahummaghfirlahum warhamhum wa’afihim wa’fu ‘anhum.

Perbedaan Router OSFPv3 vs IPv6 Router OSPF

Baru baca dokumen dari Ciscopress, ternyata:

versi/mode lama:

ipv6 router ospf 1

interface loopback0

ipv6 ospf 1 area 0

contoh:

R2#sh run int lo0
Building configuration…

Current configuration : 159 bytes
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf network point-to-point
ip ospf 1 area 0
ipv6 address 2001::2/128
 ipv6 ospf 1 area 0
end

R2#
R2#sh ipv6 ospf nei

OSPFv3 Router with ID (2.2.2.2) (Process ID 1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
11.11.11.11       1   FULL/BDR        00:00:37    5               GigabitEthernet1/0
R2#

versi baru:

router ospfv3 1

router-id x.x.x.x

interface loopback0

ospfv3 1 ipv6 area 0

contoh:

R1#sh run int lo0
Building configuration…

Current configuration : 129 bytes
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
ipv6 address 2001::1/128
ospfv3 1 ipv6 area 0
end

R1#

R1#sho ospfv3 neighbor

OSPFv3 1 address-family ipv6 (router-id 1.1.1.1)

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
11.11.11.11       1   FULL/BDR        00:00:37    6               GigabitEthernet1/0
R1#

R1#show ipv6 route ospf
IPv6 Routing Table – default – 12 entries
Codes: C – Connected, L – Local, S – Static, U – Per-user Static route
B – BGP, R – RIP, H – NHRP, I1 – ISIS L1
I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary, D – EIGRP
EX – EIGRP external, ND – ND Default, NDp – ND Prefix, DCE – Destination
NDr – Redirect, O – OSPF Intra, OI – OSPF Inter, OE1 – OSPF ext 1
OE2 – OSPF ext 2, ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2, l – LISP
O   2001::2/128 [110/2]
via FE80::A00:27FF:FE12:1C06, GigabitEthernet1/0
O   2001::11/128 [110/1]
via FE80::A00:27FF:FE12:1C06, GigabitEthernet1/0
O   2001:10:2:11::/64 [110/2]
via FE80::A00:27FF:FE12:1C06, GigabitEthernet1/0
O   2001:10:4:11::/64 [110/2]
via FE80::A00:27FF:FE12:1C06, GigabitEthernet1/0
R1#

di router lainnya, XR1:

RP/0/0/CPU0:XR1#sho ospfv3 neighbor
Sat May  6 12:49:39.045 UTC

Neighbors for OSPFv3 1

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
1.1.1.1         1     FULL/DR         00:00:37    4               GigabitEthernet0/0/0/2
Neighbor is up for 02:40:21
2.2.2.2         1     FULL/DR         00:00:34    4               GigabitEthernet0/0/0/1
Neighbor is up for 01:36:06

Total neighbor count: 2
RP/0/0/CPU0:XR1#

RP/0/0/CPU0:XR1#sho route ipv6 ospf
Sat May  6 12:51:35.657 UTC

O    2001::1/128
[110/1] via fe80::c804:15ff:fe14:1c, 02:42:12, GigabitEthernet0/0/0/2
O    2001::2/128
[110/1] via fe80::c805:15ff:fe14:1c, 01:35:21, GigabitEthernet0/0/0/1
RP/0/0/CPU0:XR1#

di versi baru ini support satu database LSA mencover IPv4 dan IPv6. Namun mekanisem transportnya menggunakan Ipv6. Begitu kata ciscopress[1].

[1] http://www.ciscopress.com/articles/article.asp?p=2294214&seqNum=4